Results 1 to 4 of 4

Thread: Golf MK3 GTi 2L 8V fuel or power issues

  1. #1

    Exclamation Golf MK3 GTi 2L 8V fuel or power issues

    Hi all,

    I have a Golf MK3 GTi 2L 8V, which I imported from the UK to Australia 6 years ago.

    It's been great, however always had a slight hesitation at 2000 revs. Also, if you started the car and revved high and take the foot off quick, it drops and can cut out. Then it takes a few minutes to reset,. If you try to start it to early, it just cuts out again and not idle.

    A month ago, this cutout event happened. I waiting the normal kind of time for a reset, and started her up. Now she is running really rough all the time, and when you put pressure on the accelerator, the car struggles to deliver power to the engine.

    We've been working on fixes at the garage.

    Firstly, the engine is timing fine and running well. No pressure test issues too. All plugs are new and sparking. I've replaced the MAF. I've tested the ECU, TWICE! No issues. There are also no error codes. I've replaced a whole lot of corroded wiring. I checked the throttle body, and it's all good.

    The one thing that is baffling, is that when you block the fuel return, the problem goes away. Firstly I swapped the lines in and out of the fuel rail to see if there were blockages. Same running issues continued. So then I replaced the fuel rail. The fuel pump also seems to be running fine. Still the running issues remain.

    Does anyone have any suggestions here. I've been working on this for a month and it's really got me stumped! It could be electrical, a sort of sensing issue on fuel delivery and return. The return fuel test is the most baffling to me...how it fixes the issue by blocking it. Maybe some kind of pressure issue...translating to bad sensing in the system?

    Any thoughts are appreciated!

    Cheers,

    Simon

  2. #2

    Default

    Hoyhoy.

    Can be frustrating, wish I could help ya with this.
    Hooroo. Eddy
    06 Shadow Blue POLO GTI

  3. #3

    Default

    Quote Originally Posted by Eddy View Post
    Hoyhoy.

    Can be frustrating, wish I could help ya with this.
    I know! It's so baffling. Now I won't have it for the start of beach days on the coast. Any ideas Eddy?

    Cheers,

    Simon

  4. #4

    Default

    Hoyhoy.

    Makes it hard to find with no error codes. I'm no mechanic sorry bud.
    Hooroo. Eddy
    06 Shadow Blue POLO GTI

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •